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Using Rhino with STL Files 

Stereolithography (SLA), or 3-D printing, is the most widely used rapid prototyping 
(RP) technology. SLA provides a way for turning a 3-D model into a solid object that 
you can hold in your hand. 

STL is the standard format for rapid prototyping systems. While STL was originally 
developed for use with stereolithography, many other processes now use it. Since 
SLA machines usually require the STL file to be a watertight mesh, Rhino provides 
tools for repairing mesh files to remove gaps. 

3-D Printing 
Using Rhino’s Bonus Tools, you can print 3dm, STL, IGES, STEP, DWG, 3DS, and 
many more file formats directly to a stereolithography printer or file.  

This allows you to take nearly any 3-D model and send it to a prototyping machine. 
As with any model going to a printer, the output STL file must be watertight. Rhino 
has many tools to repair STL files that are not watertight and to create watertight 
geometry to send to a 3-D printer. The tutorials that follow show you how to 
diagnose and repair gaps in the STL file.  

If you have a 3-D printer installed on your system, a Print 3-D menu item is added 
to Rhino's File menu, and your printer will display in the list. Currently supported 
systems include: 

• Delft Spline Systems DeskProto: www.deskproto.com 

• Roland MODELA Player: www.roland.com  

• Solidscape ModelWorks: www.solid-scape.com 

• Stratasys Catalyst: www.dimensionprinting.com  

• Z Corporation ZPrint: www.zcorp.com 

Tools for Mesh Repair 
Tools for repairing meshes and printing directly to a stereolithography printer are 
free additions to Rhino 3.0 included in the Bonus Tools plug-ins. In addition to mesh 
repair and rapid prototyping support, the Bonus Tools includes many other useful 
features that are under development. A description of the Bonus Tools is available at 
www.rhino3d.com/3/bonus.htm. You must download the Bonus Tools plug-ins to use 
the commands and features described in this document. 

To download the latest version of Bonus Tools 

 Go to www.rhino3d.com/3/bonus.htm to start the download process.

http://www.deskproto.com/
http://www.roland.com/
http://www.solid-scape.com/
http://www.dimensionprinting.com/
http://www.zcorp.com/
http://www.rhino3d.com/3/bonus.htm
http://www.rhino3d.com/3/bonus.htm


  STL File Repair in Rhinoceros 

Copyright © 2004 Robert McNeel & Associates. 5 

Basic STL Repair Tutorial 

Rhino’s Bonus Tools includes commands for analyzing and repairing STL files to make 
them watertight. There are new tools for advanced display, edge matching, selection, 
and filling holes. These tools let you manipulate meshes in ways previously not 
possible in Rhino.  

While Bonus Tools mesh covers many new commands, the commands that are used 
for STL repair can be grouped into a few categories: 

• Display 

• Remove unwanted detail 

• Display and close gaps 

• Offset (thicken) 

Display Mesh Wires 
The advanced display settings it easier to locate parts that need repair by displaying 
the mesh wires in shaded views, displaying the mesh wires in a specified color, and 
displaying backs and fronts of the mesh faces in different colors. 

To turn on advanced display options 

1 Open the model STL_Handle.3dm.  

 The mesh object displays as a mass of 
wires. 
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2 To set the viewport to shaded mode, right-
click the viewport title (Perspective) and 
from the menu, choose Shaded Display. 

 Though you can now get a better idea of 
the object’s shape, it is still not easy to find 
the information you need to repair the 
mesh in this display mode. 

 

3 With the Bonus Tools installed, from the 
Bonus menu, choose View, and then choose 
Advanced Display Settings. 

4 To show the mesh edges, in the Advanced 
Display Settings dialog box, under 
Shaded/Rendered display options, check 
Show mesh wires in shaded view. 

5 To turn the wires black, check Fixed wire 
color for all objects, and set the color to 
Black. 

 

 Mesh faces have a front and a back. The 
front direction is called the normal of the 
face. Some STL meshes need to have 
consistent normals to work correctly. By 
default, the front of a face is colored the 
layer or object color. When you run Rhino is 
shaded mode, you can show the mesh 
edges and color the backs of the mesh 
faces a different color than the fronts of the 
faces. This provides a quick check of face 
normal direction. 

6 To color the backs of the mesh faces a 
different color, check Color backfaces, and 
set the color. In these examples, 
Aquamarine was used. 

7 Click OK. 
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 Now the edges of the mesh triangles 
display in black and the backs of the faces 
are colored aquamarine, so you will easily 
be able to determine which way the face 
normals are pointing. 

 In this example, all of the back faces are 
inside the model, so they are not 
visible yet. 

 

Remove Unwanted Detail 
One of the first steps in repair is to remove detail you do not need from the model. 
In this example, you can remove the drilled holes in the bosses of the handle center. 
To do this, select the hole surfaces, delete them, and then fill in the hole that will 
be left. 

To remove holes in the boss 

1  From the Bonus menu, choose Mesh, and 
then choose Extract > Connected 
(ExtractConnectedMeshFaces command). 

 

2 At the Select mesh face or change option. 
Press Enter ( SelectFaces=LessThan 
AngleBetweenFaces=0 GetBorder=No ) 
prompt, choose the AngleBetweenFaces 
option. 

 This lets you select a single face, and Rhino 
will select all the faces that are connected 
to that face within a break angle of the 
angle setting.  

 

3 At the Angle… prompt, enter 45. 

 Forty-five degrees is a good setting to start 
with if you want the selection to stop at 90-
degree edges. 
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4 Rotate the view so you are looking down the 
hole. 

 

5 At the Select mesh face… prompt, select 
one of the faces at the back of the hole.  

  The bottom of the hole highlights. 

6 At the Select mesh face… prompt, press 
Enter to extract the faces. 

 The faces stay highlighted. 

 

7 To delete the faces, press the Delete key. 

 

8 Repeat the ExtractConnectedMeshFaces 
command. 
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9 Select one of the faces at the inside of the 
hole.  

 The inside of the hole highlights.  

10 Press Enter to extract. 

 The faces stay highlighted. 

 

11 To delete faces, press the Delete key. 

 

 

12 Repeat these steps for the other hole. 
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 With these faces removed, you can see 
inside the mesh. Since the backs of the 
faces display in a different color, you can 
tell the difference between the inside and 
outside. 

 

To fill holes in the boss 

1 From the Bonus menu, choose Mesh, and 
then choose Fill Hole (FillHole command). 

 This command closes holes with a mesh 
patch. 

 

2 At the Select mesh edge on hole 
boundary... prompt, select the open edge of 
the hole. 

 The hole fills.  

3 Repeat for the other hole. 
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Display Gaps 
Now that the larger holes of the mesh are taken care of, you can display the open 
edges that still need to be stitched. Naked edge display shows you these edges. 

To show naked edges 

1 From the Analyze menu, choose Edge 
Tools, and then choose Show Edges. 

2 At the Select surfaces, polysurfaces or 
meshes for edge display… prompt, select 
the mesh. 

 

3 In the Edge Analysis dialog box, choose 
Naked Edges. 

 

 The naked edges display in the Edge 
color. These edges have gaps. The 
command line displays the number of open 
edges. 
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Close Gaps 
Small seams in the mesh can be repaired with the MatchMeshEdge command. This 
command lets you specify a tolerance. This tolerance is the maximum distance the 
command will move the edges and points to close a gap. You can run the command 
on a whole mesh or specify edges to stitch together. 

To stitch naked edges 

1 From the Bonus menu, choose Mesh, and 
then choose Match Mesh Edge 
(MatchMeshEdge command). 

 

2 At the Select mesh edges ( PickEdges 
DistanceToAdjust=0.001 RatchetMode=No ) 
prompt, choose the DistanceToAdjust 
option. 

3 At the Pick first point or type distance 
prompt, type 1. 

 The tolerance is sensitive to the size of the 
model. For complicated models, it is 
effective to start with a small tolerance and 
then to gradually increase it. This way you 
fix the smaller problems first and keep as 
much detail as possible. 

 

4 At the Select mesh edges … prompt, select 
the mesh. 
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Final Check 
Since the output STL file must be watertight, make a final check to be sure all the 
gaps are closed. 

To check for a closed mesh 

1 From the Analyze menu, choose Edge 
Tools, and then choose Show Edges. 

2 At the Select surfaces, polysurfaces or 
meshes for edge display… prompt, select 
the mesh. 

 

3 In the Edge Analysis dialog box, choose 
Naked Edges. 

 

4 Check the command line for the number of 
naked edges. 

 A small hole in the model still needs to be 
filled. 

 

5 From the Bonus menu, choose Mesh, and 
then choose Fill Mesh Hole. 
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6 At the Select mesh edge on hole 
boundary ( JoinMesh=Yes ) prompt, select 
the open edge of the hole. 

 The hole fills.  

7 To check again for naked edges, in the Edge 
Analysis dialog box, click Add Objects and 
select the mesh again. 

 The command line display the message: 

 “Found <x> total edges; no naked edges.” 

 The file is ready to print. 

 

Advanced STL Repair Tutorial 

In this section, we will look at a few more problem areas and discuss more advanced 
repair techniques.  

Display Settings 
As in the previous examples, use the Advanced Display Settings to improve the 
visibility of problem areas in the mesh. 

To turn on advanced display settings 

1 Open the model STL_Bottle.3dm.  

2 If it has not already been done, set the 
Advanced Display Settings as discussed on 
page 5. 

3 Turn on Show mesh wires in shaded 
view. 

4 Set Fixed wire color for all objects to 
Black. 

5 Set Color backfaces to Aquamarine. 

6 Set the viewport to Shaded Display. 
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Join the Mesh 

Unlike the previous example, this mesh consists of 
separate parts.  

Try clicking the bottle to see the separate parts.  

Before investigating gaps, the model needs to be 
joined into a single mesh object. 

 

 

To join the mesh 

1 From the Edit menu choose Select Objects, 
and then choose All Objects. (SelAll 
command or Ctrl+A).  

2 From the Edit menu, choose Join (Join 
command).  

 This joins all the parts into a single mesh. 
The bottle now selects as one piece.  
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Display Gaps 
Display the open edges that need to be stitched.  

To show naked edges 

1 From the Analyze menu, choose Edge 
Tools, and then choose Show Edges. 

2 At the Select surfaces, polysurfaces or 
meshes for edge display… prompt, select 
the mesh. 

3 In the Edge Analysis dialog box, choose 
Naked Edges. 

 The naked edges display in the Edge 
color. These edges have gaps. The 
command line displays the number of open 
edges. 

 

Close Gaps 
As in the previous example, start by closing small seams in the mesh with the 
MatchMeshEdge command. 

To stitch naked edges 

1 From the Bonus menu, choose Mesh, and 
then choose Match Mesh Edge. 

 

2 At the Select mesh edges ( PickEdges 
DistanceToAdjust=1 RatchetMode=No ) 
prompt, choose the DistanceToAdjust 
option. 

3 At the Pick first point or type distance 
prompt, enter 0.01. 

 The tolerance is sensitive to the size of the 
model. For complicated models, it is 
effective to start with a small tolerance and 
then to gradually increase it. This way you 
fix the smaller problems first and keep as 
much detail as possible. 

 



  STL File Repair in Rhinoceros 

Copyright © 2004 Robert McNeel & Associates. 17 

4 At the Select mesh edges … prompt, select 
the mesh. 

 Most of the edges stitch together, but a few 
areas still need some work. 

 

Stitch Larger Gaps  
Now that you have the smaller holes of the mesh taken care of, you can use the 
MatchMeshEdge command to fix the larger holes. Because of the larger tolerance 
needed in this case, it is a good idea to select only the edge to be repaired. Using a 
large stitch tolerance on the whole mesh can remove important detail. 

To close larger gaps 

1 Zoom into the bottom of the bottle at dot A.  

 Tip: Select the dot and use the 
ZoomSelected command to zoom to it. 

 A gap runs along the bottom. This hole was 
larger than the .01 tolerance we previously 
used.  

 Use MatchMeshEdge with a larger 
tolerance to close the gap on this edge 
only. 

 

2 From the Bonus menu, choose Mesh, and 
then choose Match Mesh Edge. 

 

3 At the Select mesh edges ( PickEdges 
DistanceToAdjust=0.01 RatchetMode=On ) 
prompt, choose the DistanceToAdjust 
option. 

4 At the Pick first point or type distance 
prompt, type 0.1. 
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5 At the Select mesh edges… prompt, select 
an edge of the hole.  

 The selection expands around the whole 
gap.  

 

6 Press Enter.  

 The gap closes. 

 

7 Repeat these steps for the gap at dot B.  

Fill Holes  
Sometimes there are larger holes that demand more modeling to close. In this 
example, you can use the FillHole command to fill a selected hole. 

To fill a hole 

1 Zoom in to the bottom of the bottle at dot C.  

2 Rotate the view so you can see the hole. 
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3 From the Bonus menu, choose Mesh, and 
then choose Fill Hole (FillHole command). 

 

4 At the Select mesh edge on hole 
boundary ( JoinMesh=Yes ) prompt, select 
one edge of the hole. 

 The selection expands around the entire 
hole edge and fills the hole.  

 

Remove Geometry by Feature 
In some cases, you need to remove existing mesh faces. One way to do this is to use 
the ExtractConnectedMeshFaces command. This works well for finding mesh faces 
that are part of a feature. In this example, there are some unnecessary untrimmed 
faces. 

To remove a feature 

1 Zoom into the top of the bottle at dot D.  

 There is a small shelf of unwanted faces in 
this area. 

 

2 From the Bonus menu, choose Mesh, and 
then choose Extract > Connected 
(ExtractConnectedMeshFaces command) 
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3 At the Select mesh face or change 
option. Press Enter 
( SelectFaces=LessThan 
AngleBetweenFaces=0 GetBorder=No ) 
prompt, choose the AngleBetweenFaces 
option. 

 This lets you select a single face, and 
Rhino will select all the faces that are 
connected to that face within the specified 
angle.  

 

4 At the Angle… prompt, enter 1. 

 Setting the angle to 1 is a good way to 
find planar faces.  

 The selection expands around the edge of 
the lid.  

5 At the Select mesh face… prompt, press 
Enter to extract the faces. 

 The faces stay highlighted. 

 

6 To delete the faces, press the Delete key. 
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 Another set of untrimmed faces on the 
inside of the bottle is also a problem. 

7 Zoom into the inside of the bottle at dot E.  

8 Show the naked edges (ShowEdges 
command) so you can seen the naked edge 
on the inside of the part at dot E.  

 

9 Use the ExtractConnectedMeshFaces 
command again to select and delete the 
shelf at dot E. 
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Fill Holes between Objects 

Gaps in the lid at dots F and G need repair. This 
hole is not a single closed hole, but two edges 
that do not touch.  

A technique for fixing this type of mesh problem 
is to use the PatchSingleFace command to create 
mesh faces that connect the two faces to give 
control over how the mesh is laid out, then use 
the FillHole command to finish the filling. 

Before starting to fill the hole, we will remove the 
unwanted mesh faces and replace them with a 
patch that will fill the hole more efficiently.  

To remove the unwanted faces 

 Use the ExtractConnectedMeshFaces 
command to extract and delete the two flat 
areas on the shoulders of the bottle. 
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To patch the hole 

1 From the Bonus menu, choose Mesh, and 
then choose Patch Single Face 
(PatchSingleFace command). 

 

2 Select in the middle of an edge along one 
side of the opening.  

 

3 Select on an edge adjacent to the first edge 
across the gap.  

 This should give you a face that spans 
the gap as shown. 

 

 

4 Repeat the PatchSingleFace command at a 
similar location on the other side of the 
bottle. 
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To fill the holes 

 Use the FillHole command to fill the faces 
on the bottle shoulders. 

 

Replace Faces 
The top of the bottle is the most complicated to close. First, remove the flat areas 
that are floating out on the bottle top. This leaves a gap in the bottle top. Patch a 
few faces into the gap to make filling possible, and then fill the holes. 

To repair the shelf edge and fill the gap 

1 Zoom into the bottle top at dot D.  

 A small shelf of faces is difficult to see in 
this area. 

 

2  Show the naked edges to see the shelf. 
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3 Use the ExtractConnectedMeshFaces 
command to separate and delete the face. 

4 Set the AngleBetweenFaces option to 1. 

  

 

 

 

 Due to the colored backfaces, you can see 
the gap in the mesh. 

 

 If you use the FillHole command to fill the 
gap left at this point, the resulting mesh 
has long, thin triangles that do not match 
well with their neighbors. 
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5 Use the PatchSingleFace command to 
create a patch between two faces on either 
side of the gap.  

 This helps the FillHole command create a 
well-behaved mesh. 

 

6 Use the FillHole command to fill the gap. 

 There will still be a few small naked edges 
in the model at this point.  

7  Use the techniques described above to close 
the remaining holes. 

 

Thicken/ Shell Meshes 

Rhino has offset mesh tools that create solids from mesh surfaces or make closed 
mesh hollow. 

To offset and thicken a mesh 

1 Open the model Bottle Offset.3dm.  
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2 From the Bonus menu, choose Mesh, and 
then choose Offset Mesh (OffsetMesh 
command). 

 

3 At the Select object to mesh prompt, 
select the bottle mesh, and press Enter. 

 

4 Set the OffsetDistance option to 0.1. 

 You will see white mesh lines that preview 
the new offset mesh.  

 

5 To close the edges on the offset, set the 
CapMeshes option to Yes.  

 You can click on the mesh to flip the 
direction of the offset.  

 

6 Press Enter to execute the offset.  
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7 Rotate the view and repeat this for the cap. 

 

 You will now have a hollow bottle and cap 
for printing. 
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Mesh Tools Reference 

Standard Display Modes 
As you work with meshes, it is important to be able to change how they are 
displayed in Rhino. Five basic display modes that are particularly useful for mesh 
repair are available from the Viewport menu: Wireframe, Shaded, Ghosted, 
Rendered, and Flat Shade.  

To set the display mode 

1 Right-click the viewport name. 

2 From the menu, choose a display 
mode. 
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Display modes 

Wireframe Display 

Shows the edges of all the faces of a mesh. 
This mode works well when looking for edge 
conditions. 

 

Shaded Display 

Lets you pick visible faces. 

 

Ghosted Display 

Makes the mesh semi-transparent. 
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Rendered Display 

Shows simple color, transparency, gloss, and 
texture. Use this mode to see which colors will 
be transferred to a color 3-D printer. 

 

Flat Shade 

Meshes consist of a series of flat faces. In a 
normal shaded display mode, the mesh looks 
smooth on the screen. This smooth display 
method does not mean the mesh is actually 
smooth. To see the true structure of the mesh, 
turn on Flat Shade. Flat Shade is a toggle that 
works with all shaded modes. 
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Advanced Display Modes 
The Advanced Display Settings let you further customize how Rhino displays meshes.  

To change display settings 

 From the Bonus menu, choose View, and then choose Advanced Display 
Settings (AdvancedDisplay command). 

 Use these settings to see how a mesh is structured, making it easier to repair. 
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Advanced display options 

Show mesh wires in shaded views 

Draws the edges of a mesh so that you can 
clearly see each face. This display mode is 
probably the most useful for mesh repair.  
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Fixed wire color for all objects 

By default, the edges of the mesh faces will 
draw in a slightly lighter or darker shade of 
the object color. For mesh repair, drawing all 
wires black, regardless of the mesh object 
color, can show more contrast and make it 
easier to see how the mesh is structured. 

 

 

Fixed shaded color for all objects  

Color backfaces 

Mesh faces have a front and a back. The 
“front” direction is called the normal of the 
face. Some STL meshes will need to have 
consistent normals to print correctly. By 
default, the front of a face will be colored the 
layer or object color.  

Using Fixed shaded color for all objects 
sets the color of all front faces one color. 

Color backfaces sets all of the back faces a 
different color. These two settings let you see 
if the mesh normals are pointing in the same 
direction.  
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Use backlight 

If you look into an enclosed area of a mesh, 
backfaces may be too dark to see any detail.  

The Use backlight setting brightens the 
backfaces so you can see more detail. 

 

 

 

Analyze for Watertight Meshes 
The goal of repairing STL files is to make all the meshes in the scene watertight. 
With Rhino, you can identify open meshes and the specific edges in the mesh that 
are open. 

Select open and closed meshes 
You can select open meshes only or closed meshes only. This lets you select and  
hide closed meshes or find open meshes that need attention.  

To select open meshes 

 Use the SelOpenMesh command. 

To select closed meshes 

 Use the SelClosedMesh command. 
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Display open edges 
Once you have determined which meshes are open, you can display the open edges 
in a different color with naked edge display. Naked edge display can be on during 
other commands, so you can constantly monitor which edges are open.  

To display open edges 

 Use the ShowEdges command, and in the 
Edge Analysis dialog box, choose Naked 
Edges. 

 When you select an object, the command 
line reports the number of naked edges in 
the object. If no naked edges are 
reported, the model is watertight.  

 Open edges of a mesh can be quite small. 
Set the naked edge display to yellow or 
other high contrast color, and set the 
display mode to wireframe, so you can see 
the naked edges more clearly.   

Edit and Repair Tools 

Align normal direction 
If meshes have faces that do not all point in the same direction or faces and points 
that are not valid, the following tools can remove invalid elements. 

CullDegenerateFaces  

Bonus menu: Mesh > Utilities > Cull Degenerate 

Removes mesh faces in the model that have no area and mesh vertices that are 
not referenced by a face. 

UnifyMeshNormals 

Sets all the face normals in a mesh object to point in the same direction. 

Flip 

Reverses all the normals.  

This is especially useful if the UnifyMeshNormals command makes all the normals 
face inward and not outward. 

RebuildMeshNormals  

Bonus menu: Mesh > Utilities > Rebuild Normals 

Reconstructs all the normals of the mesh.  

Use this command when the UnifyMeshNormals command cannot get all the 
normals to face the same direction. 
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RebuildMesh  

Bonus menu: Mesh > Utilities > Rebuild Mesh 

Strips all information from a mesh and returns only the mesh geometry.  
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Extract parts 
While working on meshes, it is useful to extract parts of the mesh into their own 
separate meshes to isolate problem areas or to extract parts of the mesh that need 
to be handled as separate objects. For example, you may need to extract flat areas 
or to split a mesh in half. The mesh faces that are extracted by these commands 
form a separate mesh object. 

ExtractConnectedMeshFaces  

Bonus menu: Mesh > Extract > Connected 

Extracts parts of a mesh that are connected 
by a similar angle between faces. 

Finding an angle that works to select the 
amount of the mesh you want is a matter of 
experimentation. If the angle is too high, too 
much of the mesh will select. If it is too low, 
not enough will select.  

It may not be possible to select all of the 
mesh faces you want using one angle. In this 
case, you will have to use the command 
multiple times with different angle settings. 

Set the AngleDegree option to 1 degree to 
find planar areas. 

Set the AngleDegree option to between 10 
and 25 degrees to find features. 

Options 

SelectFaces 

If LessThan, selects faces connected at an 
angle less than the AngleBetweenFaces 
setting. 

If GreaterThan, selects faces connected at 
an angle greater than the 
AngleBetweenFaces setting. 

AngleBetweenFaces 

Sets the angle between the faces to 
compare. 

GetBorder 

If Yes, creates curves at the borders of the 
extracted faces. 
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ExtractMeshFaces  

Bonus menu: Mesh > Extract > Faces 

Extracts faces selected by picking the face or 
the face edge.  

This command works best in shaded mode, 
because you can pick the shaded faces as well 
as the face edges. 

 

ExtractMeshFacesByEdgeLength 

Bonus menu: Mesh > Extract > by Edge 
Length 

Extracts all faces that have an edge greater or 
less than a specified length.  

This command is good for removing small 
triangles or large triangles that do not belong 
in the mesh. 

In the example image, the extracted red faces 
have an edge length shorter than 0.1. 

Options 

SelectFaces 

If LessThan, selects faces with an edge 
length less than the EdgeLength setting. 

If GreaterThan, selects faces with an edge 
length greater than the EdgeLength setting. 

EdgeLength 

Sets the edge length to compare. 
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ExtractMeshFacesByAspectRatio 

Bonus menu: Mesh > Extract > by Aspect 
Ratio 

Select and extract mesh faces based on the 
ratio of length to width.  

This command is good for finding triangles 
that are very long compared to their width. A 
ratio of 25:1 or above is considered long. 

In the image, the extracted red faces have an 
aspect ratio of 9:1 or more. 

Option 

AspectRatio 

Set the target aspect ratio. 

 

ExtractMeshFacesByArea  

Bonus menu: Mesh > Extract > by Surface 
Area  

Extracts mesh faces greater than or less than 
a specified the surface area. You can specify a 
size range or pick a surface to use as an 
example size. 

This command works well for removing very 
small faces from the mesh. 

Options 

SelectFacesGreaterThan 

Selects faces with an area greater than the 
specified setting. 

SelectFacesLessThan 

Selects faces with an area less than the 
specified setting. 

PickRangeFromFace 

Sets the area by picking an example face. A 
range of ±0.1 of the area of the selected 
face is used. 
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ExtractMeshFacesByDraftAngle 

Bonus menu: Mesh > Extract > By Draft Angle 

Splits a mesh object based on the angle of the 
faces to the view.  

This command works well for splitting a mesh 
object for molds or to look for undercut areas. 

In the example, the mesh faces were selected 
in the top view. 

Options 

StartAngleFromCameraDir 

Set the starting angle from the direction of 
the viewport camera. 

EndAngleFromCameraDir 

Set the ending angle from the direction of 
the viewport camera. 

GetBorder 

If Yes, creates curves at the borders of the 
selected faces. 
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Delete parts 
Deleting parts of a mesh lets you remove errors and unnecessary detail. 

Delete mesh control points 

Turn on the mesh control points, and then 
select and delete the points by pressing the 
Delete key. 
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DeleteMeshFace  

Bonus menu: Mesh > Delete Mesh Face 

Deletes selected faces.  

This command is most effective in shaded 
mode, since you can pick the shaded surface 
and not just the mesh edges. 

 

 

ExtractDuplicateMeshFaces 

Bonus menu: Mesh > Extract > Duplicate 

Extracts duplicate faces to a separate mesh.  

 

ExtractBadMeshFaces 

Bonus menu: Mesh > Utilities > Extract Bad 
Face 

Extracts faces that do not have a normal, have 
collinear vertices, or are otherwise corrupt. 

 



  STL File Repair in Rhinoceros 

Copyright © 2004 Robert McNeel & Associates. 44 

Fill and patch holes 
Watertight meshes require that holes and open seams need to be filled or repaired. 

MatchMeshEdge 

Bonus menu: Mesh > Match Mesh Edge 

Matches open edges so they will be watertight 
based on a tolerance.  

First, the command will try to match vertices, 
then it will try to split edges to make the 
edges match. No part of the mesh is moved 
more than the specified tolerance.  

You can use this command either on the 
complete mesh or on selected edges.  

 

When selecting a whole mesh, using a high 
tolerance can create unexpected results. Use 
larger tolerances only if you select specific 
edges to close. 

Before edge, matching, magenta edges are 
open. The size of the fillet is labeled. 

 
 

 

Result after MatchMeshEdge at 0.05. 

Options 

PickEdges   

Select specific edges to match. 

DistanceToAdjust 

Set the tolerance distance. 

RatchetMode 

If Yes, matching the mesh takes place in 
four passes starting at a tolerance that is 
smaller than your specified tolerance and 
working up to the specified tolerance with 
successive passes. This matches small edges 
first and works up to larger edges. 
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FillHole 

Bonus menu: Mesh > Fill Hole 

Fills a hole in the mesh selected by picking the 
hole edge. The command searches around the 
naked edge you select and attempts to create 
a closed boundary to fill.  

Options 

JoinMesh   

If Yes, the new faces are joined to the 
original mesh. 

 

 

FillHoles 

Bonus menu: Mesh > Fill Holes 

Attempts to fill every hole in the mesh.  
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PatchSingleFace 

Bonus menu: Mesh > Patch Single Face 

Lets you select edges and vertices of a mesh 
to create a new face that connects those 
edges.  

Use the PatchSingleFace command to bridge 
gaps and then use the FillHole command to fill 
in the resulting hole. 

Options 

JoinMesh   

If Yes, the new face is joined to the original 
mesh. 
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SplitMeshEdge  

Bonus menu: Mesh > Utilities > Split Edge 

Splits a mesh edge to create two triangles.  

Use the SplitMeshEdge command to specify 
how you want to split faces, and then match 
an adjacent mesh using the MatchMeshEdge 
command. 
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AlignMeshVertices  

Bonus menu: Mesh > Align Mesh Vertices 

Moves vertices that are within a tolerance to 
the same point.  

This is good for areas that have many vertices 
that should be in the same spot, but for some 
reason are not. 

Options 

SelectVertices 

Select vertices to align. 

SelectNakedEdges 

Select naked edges to align all vertices on 
the edge. 

DistanceToAdjust 

Set the tolerance distance. 
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Collapse faces and edges 
Like the extract commands, the collapse commands find triangles in a mesh that fit 
specified criteria. Unlike the extract commands, the collapse commands move 
vertices without opening additional holes in the mesh. This is a good way to remove 
small or long and thin triangles. 

CollapseByArea 

Bonus menu: Mesh > Collapse > by Surface 
Area 

Collapses mesh faces that have surface areas 
that are greater and/or less than a specified 
number. 

Options 

SelectFacesGreaterThan 

Selects faces with an area greater than the 
specified setting. 

SelectFacesLessThan 

Selects faces with an area less than the 
specified setting. 

PickRangeFromFace 

Sets the area by picking an example face. A 
range of ±0.1 of the area of the selected 
face is used. 
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CollapseByAspectRatio  

Bonus menu: Mesh > Collapse > by Aspect 
Ratio 

Collapses mesh faces based on a specified 
ratio of length to width. A ratio of 25:1 or 
above is considered long. 

Option 

AspectRatio 

Set the target aspect ratio.  

 

CollapseByEdgeLength 

Bonus menu: Mesh > Collapse > by Edge 
Length 

Collapses all faces that have an edge greater 
or less than a specified length.  

This command is good for removing small 
triangles or large triangles that do not belong 
in the mesh. 

Options 

SelectFaces 

If LessThan, selects faces with an edge 
length less than the EdgeLength setting. 

If GreaterThan, selects faces with an edge 
length greater than the EdgeLength setting. 

EdgeLength 

Set the edge length to compare. 
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CollapseMeshEdge 

Bonus menu: Mesh > Collapse > Edge 

Collapses selected edges. The edge will be 
collapsed to one vertex. 

 

 

CollapseMeshFace  

Bonus menu: Mesh > Collapse > Face 

Collapses selected faces. The face will collapse 
to one vertex. 
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CollapseMeshVertex 

Bonus menu: Mesh > Collapse > Point 

Collapses all the faces connected to a selected 
vertex. The adjacent faces adjust to fill the 
hole. 
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Thicken/Offset Mesh Objects 
Mesh offset lets you offset the mesh to create a solid shell. 

OffsetMesh 

Bonus menu: Mesh > Offset Mesh 

Offsets the mesh a specified distance with the 
option to fill the space between the two 
surfaces to create a solid. 

Options 

OffsetDistance 

Sets the distance or thickness. 

DeleteInput 

Deletes the original surface. 

CapMeshes 

Caps the space between the original and 
new mesh to create a solid. 
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